CMC Imaging‎ > ‎Contact‎ > ‎Help‎ > ‎

Docuware 6.7 etc and SQL 2016

posted Dec 23, 2016, 9:04 AM by Craig Williams
THIS MAY NOT BE SUPPORTED BY DOCUWARE BUT I HAVE USED IT AS A WORK AROUND WITH NO ISSUES SO FAR

If you are trying to connect Docuware 6.X to SQL 2016 to sweeten data with an Auto-Index workflow you are most likely getting an error that Docuware Only supports 2008, 2012 etc......

That is, of course because 2016 had not been invented yet.  To get around this you can go to where the workflow server is located usually {DRIVE}:\Program Files (x86)\Docuware\Workflow Server and find the DocuWare.DAL.dll.config 

Open this with notepad FIND this:
<dataProvider name="SqlClient"
checkVersion="true"
CHANGE IT to look like this
<dataProvider name="SqlClient"
checkVersion="false"
Now save it if you can......

IF YOU CAN NOT....then save it to your desktop. Rename the file in the  {DRIVE}:\Program Files (x86)\Docuware\Workflow Server location to DocuWare.DAL.dll.config.OLD and then drag and drop the file from your desktop to the  {DRIVE}:\Program Files (x86)\Docuware\Workflow Server location.

Restart the workflow service and you are can now connect to SQL2016.....there may be issues and Docuware MAY NOT SUPPORT THIS, but for the short term it is a work around until you upgrade to Docuware 6.ten or greater. 


Comments